$re = '/\/\*\s+(\/\/.+)[\s\S]+\*\//m';
$str = '/*
// random unmanaged annotation
foo = var;
doSomething();
multilineFunction(a,
b);
*/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);