package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:Anakinra)\s*(\d+(?:[.,]\d+)*)\s*(g|mg|)`)
var str = `Anakinra 100 mg, gentechnologisch hergestellt aus E. coli.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}