// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:Anakinra)\s*(\d+(?:[.,]\d+)*)\s*(g|mg|)").unwrap();
let string = "Anakinra 100 mg, gentechnologisch hergestellt aus E. coli.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}