re = /(?:Anakinra)\s*(\d+(?:[.,]\d+)*)\s*(g|mg|)/m
str = 'Anakinra 100 mg, gentechnologisch hergestellt aus E. coli.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end