package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<span\b[^>]*>(?# Открывающий span с любыми атребутами
)\s*(?# Пробелы
)(\-?\d+(?:[\.\,]\d+)?)(?# Число
)\s*(?# Пробелы
)<\/span>(?# Закрывающий span)`)
var str = `<span class="company__segment__inner">0</span>
<span class="company__segment__inner">1</span>
<span class="company__segment__inner">1.</span>
<span class="company__segment__inner">1.0</span>
<span class="company__segment__inner">-1</span>
<span class="company__segment__inner">12121.12212</span>
<span class="company__segment__inner">192.168.0.1</span>
<span class="company__segment__inner">Только числа</span>
<span>1</span>
<spank>1</spank>
<span>-0,123</span>
<span>
-0,123
</span>`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}