import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = ##"""
<span\b[^>]*>(?# Открывающий span с любыми атребутами
)\s*(?# Пробелы
)(\-?\d+(?:[\.\,]\d+)?)(?# Число
)\s*(?# Пробелы
)<\/span>(?# Закрывающий span)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<span class="company__segment__inner">0</span>
<span class="company__segment__inner">1</span>
<span class="company__segment__inner">1.</span>
<span class="company__segment__inner">1.0</span>
<span class="company__segment__inner">-1</span>
<span class="company__segment__inner">12121.12212</span>
<span class="company__segment__inner">192.168.0.1</span>
<span class="company__segment__inner">Только числа</span>
<span>1</span>
<spank>1</spank>
<span>-0,123</span>
<span>
-0,123
</span>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)