const regex = new RegExp('<span\\b[^>]*>(?# Открывающий span с любыми атребутами
)\\s*(?# Пробелы
)(\\-?\\d+(?:[\\.\\,]\\d+)?)(?# Число
)\\s*(?# Пробелы
)<\\/span>(?# Закрывающий span)', 'gus')
const str = `<span class="company__segment__inner">0</span>
<span class="company__segment__inner">1</span>
<span class="company__segment__inner">1.</span>
<span class="company__segment__inner">1.0</span>
<span class="company__segment__inner">-1</span>
<span class="company__segment__inner">12121.12212</span>
<span class="company__segment__inner">192.168.0.1</span>
<span class="company__segment__inner">Только числа</span>
<span>1</span>
<spank>1</spank>
<span>-0,123</span>
<span>
-0,123
</span>`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);