import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span\\b[^>]*>(?# Открывающий span с любыми атребутами\n"
+ " )\\s*(?# Пробелы\n"
+ " )(\\-?\\d+(?:[\\.\\,]\\d+)?)(?# Число\n"
+ " )\\s*(?# Пробелы\n"
+ ")<\\/span>(?# Закрывающий span)";
final String string = "<span class=\"company__segment__inner\">0</span>\n"
+ "<span class=\"company__segment__inner\">1</span>\n"
+ "<span class=\"company__segment__inner\">1.</span>\n"
+ "<span class=\"company__segment__inner\">1.0</span>\n"
+ "<span class=\"company__segment__inner\">-1</span>\n"
+ "<span class=\"company__segment__inner\">12121.12212</span>\n"
+ "<span class=\"company__segment__inner\">192.168.0.1</span>\n"
+ "<span class=\"company__segment__inner\">Только числа</span>\n"
+ "<span>1</span>\n"
+ "<spank>1</spank>\n"
+ "<span>-0,123</span>\n"
+ "<span>\n"
+ " -0,123\n"
+ " </span>";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}