using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)""SSIDName"":""([^""]+)""";
string input = @"{""SSIDIndex"":2,""SSIDName"":""BBKH2-0272-2"" ,""Band"":""2.4GHz"",""Status"":""RadioIndex"":1,""SSIDIndex"":3,""SSIDName"":""BBH@5"",""ssidname"":""1234"" }";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}