import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\"SSIDName\":\"([^\"]+)\"";
final String string = "{\"SSIDIndex\":2,\"SSIDName\":\"BBKH2-0272-2\" ,\"Band\":\"2.4GHz\",\"Status\":\"RadioIndex\":1,\"SSIDIndex\":3,\"SSIDName\":\"BBH@5\",\"ssidname\":\"1234\" }";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}