// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?i)"SSIDName":"([^"]+)""#).unwrap();
let string = "{\"SSIDIndex\":2,\"SSIDName\":\"BBKH2-0272-2\" ,\"Band\":\"2.4GHz\",\"Status\":\"RadioIndex\":1,\"SSIDIndex\":3,\"SSIDName\":\"BBH@5\",\"ssidname\":\"1234\" }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}