package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)"SSIDName":"([^"]+)"`)
var str = `{"SSIDIndex":2,"SSIDName":"BBKH2-0272-2" ,"Band":"2.4GHz","Status":"RadioIndex":1,"SSIDIndex":3,"SSIDName":"BBH@5","ssidname":"1234" }`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}