import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^;\\n-](?<!\\b\\p{L})";
final String string = "Alwyn Howard Gentry\n"
+ "a. h. gentry\n"
+ "A H GENTRY\n"
+ "A. H. G.\n"
+ "Carl von Martius\n"
+ "Leitão Filho, H. F. ; Shepherd, G. J.\n"
+ "Dárdano de Andrade - Lima";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}