const regex = /[^;\n-](?<!\b\p{L})/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^;\\n-](?<!\\b\\p{L})', 'gmu')
const str = `Alwyn Howard Gentry
a. h. gentry
A H GENTRY
A. H. G.
Carl von Martius
Leitão Filho, H. F. ; Shepherd, G. J.
Dárdano de Andrade - Lima`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);