import re
regex = re.compile(r"[^;\n-](?<!\b\p{L})", flags=re.MULTILINE | re.UNICODE)
test_str = ("Alwyn Howard Gentry\n"
"a. h. gentry\n"
"A H GENTRY\n"
"A. H. G.\n"
"Carl von Martius\n"
"Leitão Filho, H. F. ; Shepherd, G. J.\n"
"Dárdano de Andrade - Lima")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)