$re = '/[^;\n-](?<!\b\p{L})/mu';
$str = 'Alwyn Howard Gentry
a. h. gentry
A H GENTRY
A. H. G.
Carl von Martius
Leitão Filho, H. F. ; Shepherd, G. J.
Dárdano de Andrade - Lima';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;