package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]\-[A-Z]{2}\-[A-Z]{4}\-[A-Z]{3}\-\w{4}$`)
var str = `I-KA-BGLK-ENB-V001
I-KA-AAAC-KBD-V051
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}