re = /^[A-Z]\-[A-Z]{2}\-[A-Z]{4}\-[A-Z]{3}\-\w{4}$/m
str = 'I-KA-BGLK-ENB-V001
I-KA-AAAC-KBD-V051
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end