$re = '/^[A-Z]\-[A-Z]{2}\-[A-Z]{4}\-[A-Z]{3}\-\w{4}$/m';
$str = 'I-KA-BGLK-ENB-V001
I-KA-AAAC-KBD-V051
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);