import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Z]\\-[A-Z]{2}\\-[A-Z]{4}\\-[A-Z]{3}\\-\\w{4}$";
final String string = "I-KA-BGLK-ENB-V001\n\n"
+ "I-KA-AAAC-KBD-V051\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}