using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\| 40716 \| MESSAGE \| MQTT Server Device \| Einstellungen gespeichert)|(\| CUSTOM \| Receiver video info \|)";
string input = @"06.01.2024 00:00:37 | 40716 | MESSAGE | MQTT Server Device | Einstellungen gespeichert";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}