// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\| 40716 \| MESSAGE \| MQTT Server Device \| Einstellungen gespeichert)|(\| CUSTOM \| Receiver video info \|)").unwrap();
let string = "06.01.2024 00:00:37 | 40716 | MESSAGE | MQTT Server Device | Einstellungen gespeichert";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}