re = /(\| 40716 \| MESSAGE \| MQTT Server Device \| Einstellungen gespeichert)|(\| CUSTOM \| Receiver video info \|)/m
str = '06.01.2024 00:00:37 | 40716 | MESSAGE | MQTT Server Device | Einstellungen gespeichert'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end