#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)lettre/(?!somth\?other)[^"]*""
Local $sString = "lettre/abc"" & @CRLF & _
"lettre/somth?other"" & @CRLF & _
"lettre/acc"" & @CRLF & _
"lettre/edf"de" & @CRLF & _
"lettre/nhy"" & @CRLF & _
"lettre/somth?other""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")