$re = '/lettre/(?!somth\?other)[^"]*"/m';
$str = 'lettre/abc"
lettre/somth?other"
lettre/acc"
lettre/edf"de
lettre/nhy"
lettre/somth?other"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);