#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!Vol)(?!Chapter)(?<Series>.+?(?:(?:No\.|Number) \d+)?)\s*\d*(?:[_\-#]\d+|$)"
Local $sString = "Kodoja #001 (March 2016)" & @CRLF & _
"Bleach 001-002" & @CRLF & _
"[BAA]_Darker_than_Black_Omake-1" & @CRLF & _
"The Archmage Returns After 4000 Years" & @CRLF & _
"See You in My 19th Life" & @CRLF & _
"The Return of the 8th Class Mage" & @CRLF & _
"Kaiju No. 8" & @CRLF & _
"Zom 100 - Bucket List of the Dead" & @CRLF & _
"Bleach 4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")