# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!Vol)(?!Chapter)(?<Series>.+?(?:(?:No\.|Number) \d+)?)\s*\d*(?:[_\-#]\d+|$)"
test_str = ("Kodoja #001 (March 2016)\n"
"Bleach 001-002\n"
"[BAA]_Darker_than_Black_Omake-1\n"
"The Archmage Returns After 4000 Years\n"
"See You in My 19th Life\n"
"The Return of the 8th Class Mage\n"
"Kaiju No. 8\n"
"Zom 100 - Bucket List of the Dead\n"
"Bleach 4")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.