$re = '/^(?!Vol)(?!Chapter)(?<Series>.+?(?:(?:No\.|Number) \d+)?)\s*\d*(?:[_\-#]\d+|$)/m';
$str = 'Kodoja #001 (March 2016)
Bleach 001-002
[BAA]_Darker_than_Black_Omake-1
The Archmage Returns After 4000 Years
See You in My 19th Life
The Return of the 8th Class Mage
Kaiju No. 8
Zom 100 - Bucket List of the Dead
Bleach 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);