use strict;
my $str = 'Kodoja #001 (March 2016)
Bleach 001-002
[BAA]_Darker_than_Black_Omake-1
The Archmage Returns After 4000 Years
See You in My 19th Life
The Return of the 8th Class Mage
Kaiju No. 8
Zom 100 - Bucket List of the Dead
Bleach 4';
my $regex = qr/^(?!Vol)(?!Chapter)(?<Series>.+?(?:(?:No\.|Number) \d+)?)\s*\d*(?:[_\-#]\d+|$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}