#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "``` function_block\s([\s\S]*?)```"
Local $sString = "``` function_block" & @CRLF & _
" #Cyclic" & @CRLF & _
" #Inputs" & @CRLF & _
" #Outputs" & @CRLF & _
" #Acyclic" & @CRLF & _
" #inputs" & @CRLF & _
" #outputs" & @CRLF & _
" #Optional" & @CRLF & _
" #inputs" & @CRLF & _
" #outputs" & @CRLF & _
"```"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")