$re = '/``` function_block\s([\s\S]*?)```/';
$str = '``` function_block
#Cyclic
#Inputs
#Outputs
#Acyclic
#inputs
#outputs
#Optional
#inputs
#outputs
```';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);