using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"``` function_block\s([\s\S]*?)```";
string input = @"``` function_block
#Cyclic
#Inputs
#Outputs
#Acyclic
#inputs
#outputs
#Optional
#inputs
#outputs
```";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}