package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(```` function_block\s([\s\S]*?)````)
var str = `\`\`\` function_block
#Cyclic
#Inputs
#Outputs
#Acyclic
#inputs
#outputs
#Optional
#inputs
#outputs
\`\`\``
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}