#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+([\\/. -])(?:\d+|[a-z]+)\1(\d{4})$"
Local $sString = "2\06\1998" & @CRLF & _
"21.11.1998" & @CRLF & _
"18-02-2001" & @CRLF & _
"03/05/1999" & @CRLF & _
"20 july 1999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")