using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+([\\/. -])(?:\d+|[a-z]+)\1(\d{4})$";
string input = @"2\06\1998
21.11.1998
18-02-2001
03/05/1999
20 july 1999";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}