import re
regex = re.compile(r"^\d+([\\/. -])(?:\d+|[a-z]+)\1(\d{4})$", flags=re.MULTILINE)
test_str = ("2\\06\\1998\n"
"21.11.1998\n"
"18-02-2001\n"
"03/05/1999\n"
"20 july 1999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")