import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+([\\\\/. -])(?:\\d+|[a-z]+)\\1(\\d{4})$";
final String string = "2\\06\\1998\n"
+ "21.11.1998\n"
+ "18-02-2001\n"
+ "03/05/1999\n"
+ "20 july 1999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}