#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\((\d{3})\)"
Local $sString = "(555)666-1212"
Local $sSubst = "$1-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)