use strict;
my $str = '(555)666-1212';
my $regex = qr/\((\d{3})\)/p;
my $subst = '$1-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";