package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((\d{3})\)`)
var str = `(555)666-1212`
var substitution = "$1-"
fmt.Println(re.ReplaceAllString(str, substitution))
}