const regex = /(?<={[^{}]*)([^\S\r\n]*)([A-Za-z'-]+:)(?=[^{}]*})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<={[^{}]*)([^\\S\\r\\n]*)([A-Za-z\'-]+:)(?=[^{}]*})', 'gm')
const str = `.MenuContainerScroll {
overflow: auto;
overflow-y: hidden;
white-space: nowrap;
width: 100%;
margin-top: 1vw;
}
.MenuContainerScroll::-webkit-scrollbar {
width: 6px;
height: 1vw;
}
.MenuContainerScroll::-webkit-scrollbar {
width: 6px;
height: 1vw;
`;
const subst = `$1<span class="blue">$2</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);