re = /(?<={[^{}]*)([^\S\r\n]*)([A-Za-z'-]+:)(?=[^{}]*})/m
str = '.MenuContainerScroll {
overflow: auto;
overflow-y: hidden;
white-space: nowrap;
width: 100%;
margin-top: 1vw;
}
.MenuContainerScroll::-webkit-scrollbar {
width: 6px;
height: 1vw;
}
.MenuContainerScroll::-webkit-scrollbar {
width: 6px;
height: 1vw;
'
subst = '$1<span class="blue">$2</span>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result