import re
regex = re.compile(r"(?<={[^{}]*)([^\S\r\n]*)([A-Za-z'-]+:)(?=[^{}]*})", flags=re.MULTILINE)
test_str = (".MenuContainerScroll {\n"
" overflow: auto;\n"
" overflow-y: hidden;\n"
" white-space: nowrap;\n"
" width: 100%;\n"
" margin-top: 1vw;\n"
"}\n\n"
".MenuContainerScroll::-webkit-scrollbar {\n"
"width: 6px;\n"
"height: 1vw;\n"
"}\n\n"
".MenuContainerScroll::-webkit-scrollbar {\n"
"width: 6px;\n"
"height: 1vw;\n")
subst = "$1<span class=\"blue\">$2</span>"
result = regex.sub(subst, test_str)
if result:
print(result)