use strict;
my $str = '.MenuContainerScroll {
overflow: auto;
overflow-y: hidden;
white-space: nowrap;
width: 100%;
margin-top: 1vw;
}
.MenuContainerScroll::-webkit-scrollbar {
width: 6px;
height: 1vw;
}
.MenuContainerScroll::-webkit-scrollbar {
width: 6px;
height: 1vw;
';
my $regex = qr/(?<={[^{}]*)([^\S\r\n]*)([A-Za-z'-]+:)(?=[^{}]*})/mp;
my $subst = '$1<span class="blue">$2</span>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";