using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"name=""(.+?)""|id=""(.+?)""|value=""(.+)?""";
string input = @"<input type=""hidden"" name=""Frm_Logintoken"" id=""Frm_Logintoken"" value="">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}