re = /name="(.+?)"|id="(.+?)"|value="(.+)?"/m
str = '<input type="hidden" name="Frm_Logintoken" id="Frm_Logintoken" value="">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end