#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^|\s)(\d*\.\d+)(?!\S)"
Local $sString = "There are 1.2 apples" & @CRLF & _
"1.2" & @CRLF & _
"0.2" & @CRLF & _
".2" & @CRLF & _
"Version 1.2.3 was released" & @CRLF & _
"1.2.3.4.5..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")