$re = '/(?:^|\s)(\d*\.\d+)(?!\S)/m';
$str = 'There are 1.2 apples
1.2
0.2
.2
Version 1.2.3 was released
1.2.3.4.5...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);