import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\s)(\\d*\\.\\d+)(?!\\S)";
final String string = "There are 1.2 apples\n"
+ "1.2\n"
+ "0.2\n"
+ ".2\n"
+ "Version 1.2.3 was released\n"
+ "1.2.3.4.5...";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}