const regex = /(?:^|\s)(\d*\.\d+)(?!\S)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\s)(\\d*\\.\\d+)(?!\\S)', 'gm')
const str = `There are 1.2 apples
1.2
0.2
.2
Version 1.2.3 was released
1.2.3.4.5...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}